Synthé-modulaire

Quelques lamas, sur la cordillère des ondes
 
AccueilAccueil  PortailPortail  S'enregistrerS'enregistrer  Connexion  
Partagez | 
 

 Problème séquencer PRIZMA

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Switchzik
Petit lama
avatar

Messages : 39
Date d'inscription : 16/08/2015

MessageSujet: Problème séquencer PRIZMA   Mer 25 Jan - 10:13

Salut à tous !

Je monte petit à petit mon modulaire fait uniquement de modules DIY. Jusqu'à maintenant ca c'est plutôt bien passé (avec quelques petites mésaventures) mais là je bloque.
J'ai monté mon séquenceur [Vous devez être inscrit et connecté pour voir ce lien] et j'arrive pas à faire marcher les sorties CVs.

C'est à dire que tout fonctionne, que se soit les sorties trig, les menus, les encodeurs, les leds (bonne couleur sauf pour le CV), clock etc ... mais en sortie CV je ne peux changer que de +1 et +2 tons pas plus. La led est bien verte quand je tourne l'encodeur du haut mais elles passent au bleu quand je tourne l'encodeur du bas (au lieu de vert, selecteur de la note).  Ne sais pas

De plus je n'arrive pas à faire à le calibrer proprement. Je pense pourtant faire ça bien. Je plug un jack et je prend la tension entre le jack et la terre. Tourner les potentiomètres ne change rien ! Dois-je les changer ? Changer les ICs (les mettre ou pas ne change rien ...) ? Est un probleme sotware mais tout le reste fonctionne ?

Si l'un de vous l'a déjà monté et calibré, ou si vous avez une idée je serais curieux Smile

Merci !  cheers

Schématique : [Vous devez être inscrit et connecté pour voir ce lien]
PS: J'ai déjà demandé sur Mugg et au fabricant mais sans succès pour le moment.
Revenir en haut Aller en bas
Portamento
Petit lama


Messages : 84
Date d'inscription : 06/08/2013
Localisation : PAU

MessageSujet: Re: Problème séquencer PRIZMA   Mar 31 Jan - 5:06

Hi,

Il a l'air pas mal ce séquenceur! Je ne connaissais pas ces leds (WS2812B). Elles sont inspirantes Smile
Si 'tout' fonctionne sauf la sortie CV, a priori le logiciel n'est pas à incriminer a ce stade.

J'imagine que tu as eu l'atmega328p déjà chargé ?

Je ne vais pouvoir t'aider que partiellement.
Tout d'abord est ce que le MCP4822 fonctionne correctement ? :
- Enlève les 2 CA3140.
- Génère la note la plus grave que tu puisses faire.
- Mesure la tension entre la masse et la sortie 8 puis la sortie 6 du MCP -> normalement tu dois avoir 0 volts
- Génère la note la plus aiguë que tu puisses faire.
- Mesure la tension entre la masse et la sortie 8 puis la sortie 6 du MCP -> normalement tu dois avoir 4.095 volts

Si c'est le cas on passera à d'autre questions.
Si c'est pas le cas, c'est ton MCP communique mal avec le microcontroleur ou bien qu'il est HS.
Revenir en haut Aller en bas
http://oZoe.fr
Switchzik
Petit lama
avatar

Messages : 39
Date d'inscription : 16/08/2015

MessageSujet: Re: Problème séquencer PRIZMA   Mer 1 Fév - 10:44

Salut !

Merci pour ton aide Smile
Alors je trouve sortie 6 = 0,05V et sortie 8 = 1,99V. Peut importe la note ...

A mon avis le microcontrôleur fonctionne bien car tout le reste marche.
Peut être que je peux remplacer le MCP pour commencer A la tienne
Merci !

Edit : Le sequenceur est bouré de fonctionnalité pour un encombrement réduit, dans le genre y'a pas grand chose je pense. Les leds sont superbes. On m'en a vendu des fausses sur eBay, c'est donc mon 2éme PCB Razz
Revenir en haut Aller en bas
Portamento
Petit lama


Messages : 84
Date d'inscription : 06/08/2013
Localisation : PAU

MessageSujet: Re: Problème séquencer PRIZMA   Mer 1 Fév - 10:54

Au moins tu commences à cerner la panne.
* Verifie tout de meme que tu as bien 5V entre masse et la broche 1 du MCP.
* Tu peux aussi, avec le module hors tension, tester la continuité entre la broche 16 du microcontroleur et la broche 2 du MCP, puis entre les broches 19 et 3, et enfin 17 et 4.

Si tout est OK, change le MCP.
Revenir en haut Aller en bas
http://oZoe.fr
Switchzik
Petit lama
avatar

Messages : 39
Date d'inscription : 16/08/2015

MessageSujet: Re: Problème séquencer PRIZMA   Mer 1 Fév - 11:08

Les 5V sont bien là et y'a bien continuité.
La seule chose qui me dérange c'est pourquoi quand je tourne l'encodeur 2 la couleur des LEDs qui doivent passer au vert restent bleues. Sachant que ce n'est pas le même circuit et que le MCP n'influence pas ça ?
Revenir en haut Aller en bas
Portamento
Petit lama


Messages : 84
Date d'inscription : 06/08/2013
Localisation : PAU

MessageSujet: Re: Problème séquencer PRIZMA   Mer 1 Fév - 11:15

Ca je ne sais pas te répondre. L'auteur pourra te le dire.
Revenir en haut Aller en bas
http://oZoe.fr
Switchzik
Petit lama
avatar

Messages : 39
Date d'inscription : 16/08/2015

MessageSujet: Re: Problème séquencer PRIZMA   Mer 1 Fév - 11:18

Pas de soucis. Je remplace le MCP et je reviens te dire si c'est mieux Coucou
Revenir en haut Aller en bas
Switchzik
Petit lama
avatar

Messages : 39
Date d'inscription : 16/08/2015

MessageSujet: Re: Problème séquencer PRIZMA   Lun 6 Fév - 7:43

Premier test avec le nouveau DAC concluant !
Les leds sont pas de la bonne couleur mais peut importe, ça m'a l'air bon Smile

Merci encore ! A la tienne
Revenir en haut Aller en bas
Portamento
Petit lama


Messages : 84
Date d'inscription : 06/08/2013
Localisation : PAU

MessageSujet: Re: Problème séquencer PRIZMA   Mar 7 Fév - 6:28

Génial ! A la tienne
Revenir en haut Aller en bas
http://oZoe.fr
 
Problème séquencer PRIZMA
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Synthé-modulaire :: Théories et Ressources :: Réalisations DIY-
Sauter vers: